Gen 3 Immobiliser Problem

From installing angel eyes to your indicators not working,
choosing a new head unit, or installing speakers.

Gen 3 Immobiliser Problem

Postby BILLYBONKERZ » Thu Mar 18, 2010 9:55 pm

hi, not to sure if this should be in this thread or the electrical but im sure a mod will move it if its wrong ;)

right.....2002 gen 3 1.6s, battery went flat so i took it off to charge it up, when put it back on 2 days later it refused to start and engine light came on, i used my odb2 reader and got the codes:
P1610 Sensor Reference Voltage Fault (i did kill the battery tryin to start it)
P1805 Immobilizer EEPROM Error
P1801 Immobilizer Transponder Error

i did have guy come look at it from another forum but that has since closed plus ive moved to dagenham now from canvey island, he reckoned the key may have dropped the code altho alot of people are saying its unlikely, i called a main dealer and im sure they reckoned it could be the bcm unit or something £700 lol

anyway i thought id try my luck on here with you guys as i see theres quite a few very knowledgeable people on this site :) any idea's would be greatly appreciated ?????
User avatar
BILLYBONKERZ
Casual Member
Casual Member
 
Posts: 10
Joined: Sat Jan 16, 2010 9:12 pm
Location: ESSEX
Owns: Gen 3 Hyundai Coupe
View: : Pics of My Car [?]
Move Poster Profile To The Other Side




Advertisement
Please Support The Club
 
Remove Ads With VIP
Donate using Paypal

Re: gen 3 immobiliser problem

Postby Vehicle-tech-755 » Thu Mar 18, 2010 10:04 pm

probably the same issue i have with the 2002 accent, (i believe they run the same immobilizer unit) last time i ran the Hi Scan Pro over it to check the immob status was able to find that every so often the immob wouldn't reckognise the key, and would inform me that it wasn't paired etc etc. in short i have done nothing about it as i dont have any money at the moment, i just put up with it not starting occationally, if it refuses to start i just remove the key, wait about 15 - 20 seconds for the immoboiliser to reset then it usually starts.
User avatar
Vehicle-tech-755
Casual Member
Casual Member
 
Posts: 16
Joined: Mon Mar 15, 2010 12:28 am
Location: Winchester
Owns: Gen 1 Hyundai Coupe
View: : Pics of My Car [?]
Move Poster Profile To The Other Side

Re: gen 3 immobiliser problem

Postby BILLYBONKERZ » Fri Mar 19, 2010 4:44 pm

yeah i hear alot of people have had the problem but there car starts every now and then, my one didnt give me no warning and refuses to start all together, im on the verge of just sticking it in the main dealer but i know they are gonna just slaughter me moneywise, hopefully someone will be able to help me out on here, is the bcm unit serviceable? is it definetly going to be that? could it be the key that has actually dropped its code?
User avatar
BILLYBONKERZ
Casual Member
Casual Member
 
Posts: 10
Joined: Sat Jan 16, 2010 9:12 pm
Location: ESSEX
Owns: Gen 3 Hyundai Coupe
View: : Pics of My Car [?]
Move Poster Profile To The Other Side

Re: gen 3 immobiliser problem

Postby Jrp210 » Fri Mar 19, 2010 4:50 pm

Your best of giving a Sharky (Tiburon Automotive: 0121 766 6254Sponsor) a ring he will bea able to tell you.

Contact info here
User avatar
Jrp210
Club Addict
Club Addict
 
Posts: 4005
Joined: Tue Jul 07, 2009 2:28 pm
Location: Grimsby
Owns: Gen 3 Hyundai Coupe
View: : Pics of My Car [?]
Move Poster Profile To The Other Side

Re: gen 3 immobiliser problem

Postby BILLYBONKERZ » Fri Mar 19, 2010 5:08 pm

funny enough i sent him a message earlier on today as he helped me out a couple of months ago ;)
User avatar
BILLYBONKERZ
Casual Member
Casual Member
 
Posts: 10
Joined: Sat Jan 16, 2010 9:12 pm
Location: ESSEX
Owns: Gen 3 Hyundai Coupe
View: : Pics of My Car [?]
Move Poster Profile To The Other Side

Re: gen 3 immobiliser problem

Postby Joff » Fri Mar 19, 2010 5:18 pm

He's been uber busy recently so you might not get a reply for a long while unless you try phoning him
User avatar
Joff
Club Addict
Club Addict
 
Posts: 3366
Joined: Sun Oct 04, 2009 1:49 pm
Location: Ringwood, Hampshire
Owns: Non Hyundai Coupe
View: : Pics of My Car [?]
Move Poster Profile To The Other Side

Re: gen 3 immobiliser problem

Postby BILLYBONKERZ » Sat Mar 20, 2010 3:24 pm

just to update, just put a fully charged battery on the car and it started up straight away but the indicators are flashing non stop and the alarm was sounding until i unplugged the horn, the fob does absolutely nothing, not even unlocking the doors, the central locking wont work even by the key or manually moving the lock. i took out the BCM unit(i cant believe they want 700 quid for it) and unplugged it and re-connected it incase of a lose connection, end result, car starts straight away, fob is still useless, indicators still flashing but alarm not sounding now... any idea's?
User avatar
BILLYBONKERZ
Casual Member
Casual Member
 
Posts: 10
Joined: Sat Jan 16, 2010 9:12 pm
Location: ESSEX
Owns: Gen 3 Hyundai Coupe
View: : Pics of My Car [?]
Move Poster Profile To The Other Side

Re: Gen 3 Immobiliser Problem

Postby Joff » Sat Mar 20, 2010 6:36 pm

Def sounds like BCM has gone. Possible fix here but I think that only covers the indicators

£700 is about what dealers normally charge. Might get lucky and find one on eBay cheap. Needs to be 'reactivated' after it's installed I believe
User avatar
Joff
Club Addict
Club Addict
 
Posts: 3366
Joined: Sun Oct 04, 2009 1:49 pm
Location: Ringwood, Hampshire
Owns: Non Hyundai Coupe
View: : Pics of My Car [?]
Move Poster Profile To The Other Side

Re: Gen 3 Immobiliser Problem

Postby BILLYBONKERZ » Sun Mar 21, 2010 3:16 pm

thanks for the info but i dont think its goiing to do me much good lol... just took out the bcm unit and was opening it up to do the little job for the indicators when i found this:

http://i886.photobucket.com/albums/ac61 ... 0_0608.jpg
and
http://i886.photobucket.com/albums/ac61 ... 0_0607.jpg

pictures taken in hi-res so you can zoom in and see that there seems to have been some sort of water damage that has burnt out a good few little black thingy resistors, i call them blocks, it also appears that there are a couple actually burnt off or disintigrated lol
ive tried to show them in the pictures in the circles.

so it looks like the main dealer are going to get my £700 after all unless someone knows the location of one :shock:
User avatar
BILLYBONKERZ
Casual Member
Casual Member
 
Posts: 10
Joined: Sat Jan 16, 2010 9:12 pm
Location: ESSEX
Owns: Gen 3 Hyundai Coupe
View: : Pics of My Car [?]
Move Poster Profile To The Other Side

Re: Gen 3 Immobiliser Problem

Postby Labrat of Larbert » Sun Mar 21, 2010 5:11 pm

OOH! Bad luck mate.
Any chance you could do us fellow Gen3 owners a favour and see if you can find the source of the water ingress, and maybe describe how we could prevent a similar tale of woe?
I'm sure we can all find an alternative use for £700 :)
User avatar
Labrat of Larbert
Club Regular
Club Regular
 
Posts: 604
Joined: Wed Jul 22, 2009 8:37 pm
Location: Falkirk, Scotland
Owns: Gen 3 Hyundai Coupe
View: : Pics of My Car [?]
Move Poster Profile To The Other Side

Re: Gen 3 Immobiliser Problem

Postby Jrp210 » Sun Mar 21, 2010 11:03 pm

Have a chat with Sharky (Tiburon Automotive: 0121 766 6254Sponsor) he maybe able to supply and fit alot cheaper.
User avatar
Jrp210
Club Addict
Club Addict
 
Posts: 4005
Joined: Tue Jul 07, 2009 2:28 pm
Location: Grimsby
Owns: Gen 3 Hyundai Coupe
View: : Pics of My Car [?]
Move Poster Profile To The Other Side

Re: Gen 3 Immobiliser Problem

Postby BILLYBONKERZ » Mon Mar 22, 2010 11:06 am

just spoke to Sharky (Tiburon Automotive: 0121 766 6254Sponsor), i think im going to order the bcm off him seeing as hes over £100 cheaper than my local hyundai dealer ;) going to try a few reputable salvage places first to see if i can get a neutralised bcm unit as Sharky (Tiburon Automotive: 0121 766 6254Sponsor) said theres no point just getting one from a scrapyard as it probably wont be neutralised on the car it came from and will therefore be useless... also ive got to try find the source of the water leak as obviously it will only happen again, Sharky (Tiburon Automotive: 0121 766 6254Sponsor) reckons possible leaky screen due to the bcm's location, il update on here as soon as i get a chance to investigate ;)
User avatar
BILLYBONKERZ
Casual Member
Casual Member
 
Posts: 10
Joined: Sat Jan 16, 2010 9:12 pm
Location: ESSEX
Owns: Gen 3 Hyundai Coupe
View: : Pics of My Car [?]
Move Poster Profile To The Other Side



Advertisement
Please Support The Club
 
Remove Ads With VIP
Donate using Paypal

Return to Audio, Electrical & Lighting

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 1 guest

Explore The Club
Join In
Support Our Sponsors